Technical Issue with Ticketing System

Incident Report for Red Canary

Resolved

This issue has been resolved.
Posted Jun 30, 2025 - 14:44 UTC

Identified

We have identified a technical issue with our ticketing system that is preventing us from viewing ticket details. All tickets are currently affected.
We are actively working with our support vendor to get this resolved.
Posted Jun 30, 2025 - 14:11 UTC
This incident affected: Customer Support.