Data Processing Delays for Google Workspace

Incident Report for Red Canary

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 22:18 UTC

Identified

We identified an issue impacting data processing for Google Workspace customers and have implemented a fix. Detections may be delayed.
Posted Oct 27, 2025 - 21:06 UTC
This incident affected: Detections.