Investigating issues resulting from reported Azure outage

Incident Report for Red Canary

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 22:18 UTC

Monitoring

Microsoft Office 365 external service integrations are now functioning as expected. Detections may be delayed as we process the backlog.
Posted Oct 29, 2025 - 21:43 UTC

Investigating

We are aware of a reported degradation with the manage.office.com domain that is impacting some Microsoft Office 365 services. At this time telemetry and detections for Microsoft Office 365 External Service Integrations may be delayed.
Posted Oct 29, 2025 - 17:16 UTC
This incident affected: Detections and Identity Telemetry Ingestion (Microsoft Office 365).